[Bug 845] Received disconnect from ???: 2: Corrupted MAC on input.

bugzilla-daemon at bugzilla.mindrot.org bugzilla-daemon at bugzilla.mindrot.org
Tue May 3 14:08:48 EST 2011


Devin Reade <gdr at gno.org> changed:

           What    |Removed                     |Added
                 CC|                            |gdr at gno.org

--- Comment #12 from Devin Reade <gdr at gno.org> 2011-05-03 14:08:48 EST ---
[More details for posterity]

For what it's worth, a few months back I found myself dealing with this
situation in a couple of variants.  In one case, one end of the SSH
session was to a VM in a Xen environment.  In another case, one end of
the SSH session was to a VM in a VMWare ESXi environment.

Copying anything via scp or sfp was almost impossible, although
interactive shells usually worked.

In both cases, after lots of diagnosis and "google research" I was able
to determine that the underlying cause seemed to be a faulty TCP
segment offload mechanism in the underlying virtualized network layer. 
(In one case, fingers were pointed at a virtual switch, in the other to
the virtual NIC.)  Either way, it appears that the VM's kernel was
offloading checksumming to the lower layers, but none of the lower
layers actually bothered to do it.

Disabling TCP segment offload in the upper level of the network stack
(that of the VM OS) solved the problem and the systems have been fine
since then.

This *does* tend to indicate that it's not an SSH problem per se.

Configure bugmail: https://bugzilla.mindrot.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are watching someone on the CC list of the bug.

More information about the openssh-bugs mailing list