[Bug 845] Received disconnect from ???: 2: Corrupted MAC on input.

bugzilla-daemon at bugzilla.mindrot.org bugzilla-daemon at bugzilla.mindrot.org
Sat Dec 8 11:59:35 AEDT 2018


--- Comment #18 from Dan <openssh at blazemonger.com> ---
OK, I ran a bunch of tests on my home network, which consists of an 
ActionTec MI424WR router (for Verizon FIOS) connected to a Cisco
24-port switch (Procure 1400-24G), wired by CAT-6 to the various

I ran scp on my Linux box (Ubuntu 16.04), trying to copy huge files
from another host.

It works when the remote host is another computer on my  home network
(a Mac). So the problem can't be the Cisco switch or the Linux

It fails when the remote host is on the internet. I tried two different
internet Linux hosts (one Linode, one HostDime). Both scp operations
died partway through the transfer. The Linux box said:

  ssh_dispatch_run_fatal: Connection to xx.xx.xx.xx port xxx: message
authentication code incorrect

and the Mac said:

  Corrupted MAC on input.
  Disconnecting: Packet corrupt

So the problem is either the ActionTec router, the Verizon hookup in my
basement, or something outside my home. Wheeee.

You are receiving this mail because:
You are the assignee for the bug.
You are watching someone on the CC list of the bug.

More information about the openssh-bugs mailing list