3.1p1 breaks X11 forwarding

Bob Proulx bob at proulx.com
Tue Mar 12 20:34:53 EST 2002

> > >      X11UseLocalhost
> > I don't think that is the problem.  
> Don't discuss with developers, try it out.

I get to eat my own words.  I apologize for second guessing Kevin.  I
was fixated on the changes from 2.9.9 to 3.0.2 to 3.1 and was in
disbelief at how something that obviously could not be the problem
could be the problem.

I tried the following:

  sshd -p 2200 -o 'PidFile /tmp/sshd.pid' -o 'X11UseLocalhost no'

And it worked!  The different X11 programs all worked fine.  That
appears to resolve the problem.

> Some X11 apps are "difficult" when it comes to $DISPLAY and -
> there was a long thread in the mailing list about this a few months ago.

I will have to search the archives some more and see what that was all
about.  On the surface it makes no sense to me that a program would
know the difference between "localhost" which resolves to
which is a valid address and "hostname" which resolves to
which is also a valid address.  [Something to do with the old unix:0
issue?]  But if this has all been discussed before I don't want to
drag people down again with it now.

Thanks for excellent assistance.  Even if I did prove myself wrong in
the process.  :-)


More information about the openssh-unix-dev mailing list