patch for password expiration under Solaris?

Iain Morgan imorgan at
Wed Mar 13 08:09:16 EST 2002

Bug 14 includes a patch that is essentially Dave's patch. That worked up 
through 3.0.2p1. I tried it with 3.1.p1 and the patch did not apply

You should be able to avoid the issue for Solaris by using PAM.
Use the --with-pam configure options.

On Mon Mar 11 19:04:07 2002, Mordechai T. Abzug wrote:
> I'm looking to move some Solaris 2.6 and 7 machines to openssh.
> Showstopper bug: openssh (up to 3.1p1) doesn't seem to correctly
> implement expired passwords.
> Looking back through the archive, it looks like Dave Dykstra submitted
> a patch for this problem relative to an older version of openssh at
> least as early as last August:
> The patch seems to work on one of my test machines, after some minimal
> finagling.  Is this patch the standard solution to this problem?
> Thanks!
> - Morty
> _______________________________________________
> openssh-unix-dev at mailing list

Iain Morgan
NAS Desktop Support Group

More information about the openssh-unix-dev mailing list