openssh 3.1p1 linking problem

Noah Friedman friedman at
Thu Mar 21 09:42:05 EST 2002

It's recommended that recent versions of openssl be built only as static
libraries because the ABIs are not yet stable (esp. the `engine'
component).  However, the library still uses dlopen.

Linking openssh will therefore fail unless linking against -ldl explicitly
along with -lcrypto.  It should be harmless to do so when linking

Also, it would be useful if the configure script for openssh would check
for the minimum version of openssl required.  Version 0.9.5 did not define
some functions that openssh wanted; I had to upgrade to 0.9.6.

More information about the openssh-unix-dev mailing list