openssh 3.7p1 and 3.7.1p1 Solaris problems

Bradley Guenther guenth at
Thu Sep 18 02:50:11 EST 2003

I have some Solaris 7 boxes (Ultra 3 and Ultra Enterprise 250 hardware) 
that I have compiled both 3.7p1 and 3.7.1p1 on and am having some 
problems.  I am using the same "configure" options that I have in the 
past (without problems).  I have tried both new and existing (previously 
working) ssh_config and sshd_config files.  The new versions seem to 
have broken SSH 1 support (and maybe cause a bit of SSH 2 problems).  
All of my unix boxes can ssh into the server fine.  Cygwin users can ssh 
in fine.  TeraTerm Pro (both the old one that supports ssh1 only and the 
new one which <allegedly> supports ssh2) both just keep prompting me for 
my password over and over again.  Putty v.52 (older version) crashes 
when I try  to connect via ssh2, and gives me "Access denied" on 
attempts via ssh1.  The latest version (as of last night at least) of 
Putty works on ssh2 but still gives me the "Access denied" over and over 
again on ssh1 attempts.  Winscp basically works, but prompts for the 
password twice.

I looked at a previous post to your list archives about a bus error on 
Solaris and tried that patch to no avail.  I have experienced no crashes 
on the server side.  Any ideas on this would be welcomed.

Thank you for your time,


Bradley Guenther
Computer Information Specialist

Dept. of Electrical and Computer Engineering
Kansas State University

Office: 290 Rathbone Hall
Phone:  785-532-4690
Email:  brad at

More information about the openssh-unix-dev mailing list