openssh 3.7.1p2 afs/pam issues

ERIC K. CHEU ekcheu at
Fri Sep 26 00:24:08 EST 2003

I've been trying to get a working version of openssh-3.7.1p2 as well.
Unfortunately, afs support has been pulled, and the patch posted on the
openafs list coredumps when I compile it.  The new way that pam is done
also introduces errors since pam_authenticate is supposedly called in a
seperate thread so that the correct environmental variables are not
passed.  Even after applying some changes on the openafs list, I'm still
not able to get tokens (although I am able to log in at least) when
logging in.

I've noticed that the new version also breaks Putty using protocol version
2 with AFS (although it works okay if you don't use pam or if you log into
a local account, such as root).

More information about the openssh-unix-dev mailing list