[Bug 3512] net-misc/openssh-9.1_p1: stopped accepting connections after upgrade to sys-libs/glibc-2.36 (fatal: ssh_sandbox_violation: unexpected system call)

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Fri Jan 13 22:56:53 AEDT 2023


alarig at swordarmor.fr changed:

           What    |Removed                     |Added
                 CC|                            |alarig at swordarmor.fr

--- Comment #12 from alarig at swordarmor.fr ---
(In reply to Darren Tucker from comment #9)
> (In reply to Damien Miller from comment #7)
> > idk what is calling tgkill(2) - sshd isn't threaded
> Maybe OpenSSL?  You could test this theory by configuring OpenSSH
> --without-openssl and seeing if the problem persists.


I ran into the same issue (also running Gentoo on an old kernel).
I disabled the ssl flag and applied the patch, but I still have the
unexpected system call)

I also tried to downgrade dev-libs/libgcrypt to 1.9.4-r2 and
net-misc/openssh to 9.0 and 8.9.
libgcrypt didn’t change anything
Older openssh don’t print anything on the server side, but the
connection is refused with the same errors on the client side.

I don’t know if it’s relevent, but on the configure output I have
checking for getentropy... yes
Which questions me, as I have a 3.16 kernel, which doesn’t support it.

You are receiving this mail because:
You are watching the assignee of the bug.
You are watching someone on the CC list of the bug.

More information about the openssh-bugs mailing list