[Bug 3512] net-misc/openssh-9.1_p1: stopped accepting connections after upgrade to sys-libs/glibc-2.36 (fatal: ssh_sandbox_violation: unexpected system call)

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Fri Jan 13 23:46:36 AEDT 2023


--- Comment #13 from Darren Tucker <dtucker at dtucker.net> ---
(In reply to alarig from comment #12)
> I ran into the same issue (also running Gentoo on an old kernel).
> I disabled the ssl flag and applied the patch, but I still have the
> unexpected system call)
> I also tried to downgrade dev-libs/libgcrypt to 1.9.4-r2 and

OpenSSH doesn't use gcrypt at all.  It does use libcrypto from openssl
but that's something else entirely.

> checking for getentropy... yes
> Which questions me, as I have a 3.16 kernel, which doesn’t support
> it.

It would appear that your glibc has the function call, although it
doesn't work (due to the lack of kernel support for it).

Anyway, I had 1 attempt at installing Gentoo to reproduce this but ran
out of patience.  Since every Gentoo build is effectively globally
unique, this is up to someone with an affected system to diagnose (or
provide comprehensive repro steps).  I'd suggesting starting with the
backtrace suggested in comment#8 and comment#10.

You are receiving this mail because:
You are watching the assignee of the bug.
You are watching someone on the CC list of the bug.

More information about the openssh-bugs mailing list