DG/UX R4.20MU03

David Dulek ddulek at fastenal.com
Tue Apr 11 08:21:50 EST 2000

That did the trick other than all the --with options I got it to work.


----------  Forwarded Message  ----------
Subject: Re: DG/UX R4.20MU03
Date: Sat, 8 Apr 2000 17:31:55 +1000 (EST)
From: Damien Miller <djm at mindrot.org>

On Fri, 7 Apr 2000, David Dulek wrote:

> Has anyone had any experience with ssh and DG/UX?  I tried the
> ./configure and it could not determine the hosttype.  After that
> problem was worked-arounded I get a LOT of warnings about declaring
> functions multiple times and then the compile fails with:
> packet.c: In function `packet_set_interactive':
> packet.c:803: `IPTOS_LOWDELAY' undeclared (first use this function)
> packet.c:803: (Each undeclared identifier is reported only once
> packet.c:803: for each function it appears in.)
> packet.c:815: `IPTOS_THROUGHPUT' undeclared (first use this function)
> suggestions would be nice but I am figuring I will be here awhile
> figuring this out.

Just add them manually for now, they are not platform specific:

# define IPTOS_LOWDELAY 			0x10
# define IPTOS_THROUGHPUT  		0x08
# define IPTOS_RELIABILITY 		0x04
# define IPTOS_LOWCOST  			0x02

These are being added to defines.h as I type :)


| "Bombay is 250ms from New York in the new world order" - Alan Cox
| Damien Miller - http://www.mindrot.org/
| Email: djm at mindrot.org (home) -or- djm at ibs.com.au (work)


Dave Dulek
System Administration
Fastenal Company
E-mail: ddulek at fastenal.com
Phone: (507) 453-8149
Fax:   (507) 453-8333

More information about the openssh-unix-dev mailing list