Post-compile RSA error with 1.2.2, Solaris 7, OpenSSL 0.9.5

Ben Taylor bent at
Thu Mar 2 06:52:56 EST 2000

On Wed, 1 Mar 2000, Rip Loomis wrote:

> If I try to ssh to a host that is running SSH, or I try to start the local
> sshd, I get (with the appropriate program name in place of $0):
> $0: no RSA support in libssl and libcrypto -- exiting.  See ssl(8)
> I've looked through the archives and glanced at the source, but nothing
> jumps out as the obvious cause.  Other folks seem to have OpenSSH up
> on Solaris 7 already--so does anyone have any hints as I start trying to
> RTFM and RTFS?
> Note:  After my first attempt blew up, I also tried (as an alternate
> method) downloading, compiling, installing, and linking against RSAREF2.
> That apparently worked okay, but the end result was the same.  Any chance
> that SSH found the correct libraries at compile time, but can't find them
> at runtime?

Rebuild openssl.  It has links into the rsaref2 code.  Other than
that, it sounds like my setup.


More information about the openssh-unix-dev mailing list