Post-compile RSA error with 1.2.2, Solaris 7, OpenSSL 0.9.5

Rip Loomis rip at
Thu Mar 2 07:01:26 EST 2000

Sorry I wasn't clear in my first message.  I *have*
rebuilt OpenSSL 0.9.5 linked against the RSAREF2 code,
but OpenSSH still can't find any RSA support.  (The
error message is exactly the same).  That tends to
indicate that the problem isn't in OpenSSL, it's
in the configuration of my local system or in the
way OpenSSH autoconf works.  (Another message
asked if I was sure that RSA was enabled in
OpenSSL--the answer is yes, since I compiled
OpenSSL myself, and RSA is enabled by default).

It looks as though even though the autoconf notes
that it found OpenSSL, there's a problem with my
library paths such that libssl can't be found.
I'm not sure yet, but I'm guessing that the problem
is at runtime rather than compile time.

If anyone has other suggestions, feel free to send them
directly to me, and I'll summarize to the list
when I sort things out.  Thanks--


On Wed, 1 Mar 2000, Ben Taylor wrote:

> On Wed, 1 Mar 2000, Rip Loomis wrote:
> > If I try to ssh to a host that is running SSH, or I try to start the local
> > sshd, I get (with the appropriate program name in place of $0):
> > $0: no RSA support in libssl and libcrypto -- exiting.  See ssl(8)
> > 
> > I've looked through the archives and glanced at the source, but nothing
> > jumps out as the obvious cause.  Other folks seem to have OpenSSH up
> > on Solaris 7 already--so does anyone have any hints as I start trying to
> > RTFM and RTFS?
> > 
> > Note:  After my first attempt blew up, I also tried (as an alternate
> > method) downloading, compiling, installing, and linking against RSAREF2.
> > That apparently worked okay, but the end result was the same.  Any chance
> > that SSH found the correct libraries at compile time, but can't find them
> > at runtime?
> Rebuild openssl.  It has links into the rsaref2 code.  Other than
> that, it sounds like my setup.
> Ben

More information about the openssh-unix-dev mailing list