following your openssh footsteps

Mate Wierdl mw at
Tue Mar 14 04:37:46 EST 2000

On Mon, Mar 13, 2000 at 07:43:09AM -0800, jeet M wrote:
> Mate,
> I seem to be doing the same install you are for open
> ssh on a solaris 7 box.  I am getting the same error
> you did when starting sshd (no RSA support in libssl
> and libcrypto ...).  I've installed zlib,
> openssl-0.9.5 and egd-0.6, did the LDFLAGS and CFLAGS
> declarations and configured --with-egd pointing to my
> file.

I have not been able to make openssh work with openssl-0.9.5.  I could
make it work with openssl-0.9.4.  But I *had* to install rsaref.

I have to add that I do have /dev/random.

Here is how I configured 


./config -d --prefix=/space/local --openssldir=/space/local/openssl \
         --install_prefix="$RPM_BUILD_ROOT" \

then I ran make as

make  PEX_LIBS="-L. -L.. -L../.. -L../../.. -L/space/local/lib"


LDFLAGS="-L/space/local/lib" \
LIBS="-L/space/local/lib" \
CFLAGS="-I/space/local/include" \
LD=/usr/ccs/bin/ld ./configure  --prefix=/space/local \
                                    --with-tcp-wrappers \
                                    --with-random="/dev/random" \
                                    --sysconfdir=/space/local/etc/ssh \



More information about the openssh-unix-dev mailing list