TEST RELEASE: 1.2.3pre3

Mate Wierdl mw at moni.msci.memphis.edu
Thu Mar 16 06:11:14 EST 2000

On Wed, Mar 15, 2000 at 10:33:20AM -0500, David G. Hesprich wrote:
> I had to change the LDFLAGS to get this release to work on my Solaris 2.7
> box:
> removed "-L/usr/ucblib", "-R/usr/ucblib", "-L/usr/local/ssl" and
> "-R/usr/local/ssl" (not necessary to get sshd to run, they're just
> superfluous).
> added "-L/usr/local/lib" and "-R/usr/local/lib" (to get rid of the can't
> find zlib problem when starting sshd from a default environment where
> LD_LIBRARY_PATH isn't set - my zlib is in /usr/local/lib).

In my case, I do have zlib in /usr/local/lib, and 



LDFLAGS="-L/usr/local/lib -R/usr/local/lib"

is not enough.  Indeed, I tried 


LDFLAGS="-L/usr/local/lib -R/usr/local/lib" \
./configure  --prefix=/space/local

but I still have

ssh mw at moni
ld.so.1: ssh: fatal: libz.so: open failed: No such file or directory

I think this is because in the Makefile, I still see

LDFLAGS=-L. -L/usr/ucblib -R/usr/ucblib -L/space/local/lib
-L/space/local -R/space/local/lib -R/space/local

so no /usr/local anywhere.

I'd like to add, that the only way I could make ssh work was to move
zlib to /space/local/lib.  Alternatively, all worked if I did

./configure --prefix=/space/local

make LDFLAGS="-L. -L/space/local/lib -R/space/local/lib
-L/usr/local/lib -R/usr/local/lib"

Perhaps configure could detect this problem of ssh not finding
zlib---I see the problem *only* after compiling, and then trying to
run ssh.  


More information about the openssh-unix-dev mailing list