Password and RH 6.1

Nalin Dahyabhai nalin at
Thu Mar 30 23:10:15 EST 2000

On Wed, Mar 29, 2000 at 11:22:53PM -0800, Paul Thomas wrote:
> >Since Damien builds OpenSSH and uses it on Red Hat Linux 6.1 systems,
> >there must be something funky about either the configuration of your
> >system or the way you configured and compiled OpenSSH.  Please help us
> >help you and discover what the differences are.
> This is possible. I just tried to install Damien's RPM and get
> the following:
> [root at chime src]# rpm -ivh openssh-1.2.3-1.i386.rpm
> error: failed dependencies:
>         openssl   is needed by openssh-1.2.3-1
>         openssl is needed by openssh-1.2.3-1
> is needed by openssh-1.2.3-1
> I have already installed and compiles Openssl, did a make test
> and it passed so I did a make install. I don't seem to have
> anywhere on my system. If there is an Openssl
> RPM I couldn't find it at

The failed dependency messages are there because RPM's database doesn't
include the fact that you built and installed OpenSSL manually.  There
should be ready-made packages of OpenSSL in the same directory as the
one you got OpenSSH from.

If you don't use the RPM packages, you can still get things running by
adding the directory your libcrypto was installed in to /etc/,
running "/sbin/ldconfig", and installing OpenSSH using RPM's "--nodeps"

If you're uncertain of where OpenSSL got installed, running
'find /usr -name "libcrypto*" -print' should give you a listing of any
files under /usr with names that start with libcrypto.


More information about the openssh-unix-dev mailing list