OpenSSH compile error when enabling S/Key support

Axel Wagner axwagner at
Wed May 10 05:54:37 EST 2000


I know this issue has been addressed previously, but
I'm still not able to compile OpenSSH with S/Key support.

My System:

SuSE Linux v6.3 (Kernel: 2.2.13)
OpenSSL 0.9.5a
S/Key 1.1
OpenSSH v1.2.3 / v2.0.0beta1 (error occurs in both versions)

When I tried to configure (v2.0.0beta1 as an example) as follows:

LDFLAGS="-L/usr/local/openssl-0.9.5a/lib -L/usr/local/skey-1.1/lib"  
./configure --prefix=/usr/local/openssh-2.0.0beta1      
            --with-ssl-dir=/usr/local/openssl-0.9.5a/lib --with-skey  

a subsequent make will eventually die with:

gcc -o sshd sshd.o auth.o auth1.o auth2.o auth-rhosts.o auth-krb4.o
auth-pam.o auth-passwd.o auth-rsa.o auth-rh-rsa.o pty.o log-server.o
login.o servconf.o serverloop.o bsd-login.o md5crypt.o session.o -L.
-L/usr/local/openssl-0.9.5a/lib -L/usr/local/skey-1.1/lib -lssh -ldl
-lnsl -lz  -lutil -lpam -lcrypto  -lskey -lwrap
auth1.o: In function `do_fake_authloop1':
auth1.o(.text+0x126): undefined reference to `skey_fake_keyinfo'
auth1.o: In function `do_authloop':
auth1.o(.text+0x803): undefined reference to `skey_fake_keyinfo'
collect2: ld returned 1 exit status
make: *** [sshd] Error 1

Any Idea? Help would be very appreciated.

Axel Wagner
Axel Wagner                    Internet Consulting und Webdesign

Julius-Konegenstr. 19   Tel.  : 0531/2502642   Fax: 0531/2502176
D-38114 Braunschweg     E-Mail: axel at  WWW:

More information about the openssh-unix-dev mailing list