Solved: on Solaris, "couldn't wait for child '...' completio

John Horne J.Horne at
Sat May 20 01:48:33 EST 2000

On 19-May-00 at 14:20:26 Andre Lucas wrote:
> If you're not using 2.1.0p1, please check it out - other bugs are fixed
> there too. I'll post a cure for the 'missing fixprogs' problem later
> today, just install ssh_prng_cmds manually until then.
Many thanks to the people who have replied with fixes. I noticed that
'configure' had a '--with-entropy-timeout' option which could be used to set
the value as well.

I have obtained 2.1.0p1 and it seems to work fine.

Next problem though is that it (sshd I assume) seems to create
/var/adm/utmp. I ran configure with '--with-utmpx' which is fine (to use
utmpx) but utmp itself shouldn't be present. The Solaris man page says:

     The utmp and wtmp database files are  obsolete  and  are  no
     longer  present on the system.  They have been superseded by
     the extended database contained in the utmpx and wtmpx data-
     base files.  See utmpx(4).

     It is possible for /var/adm/utmp to reappear on the  system.
     This  would  most  likely occur if a third party application
     that still uses utmp recreates the file if it finds it miss-
     ing.  This  file should not be allowed to remain on the sys-
     tem. The user should investigate to determine which applica-
     tion is recreating this file.

The file does remain on the system and gets flagged as an error:

May 19 08:03:39 bb /usr/lib/utmpd[223]: [ID 268571 daemon.warning] WARNING:
  /var/adm/utmp exists!

once per hour on the system. I could change syslog so as not to see the
message, but I think that is getting round it and not solving it.

Many thanks,


John Horne, University of Plymouth, UK             Tel: +44 (0)1752 233914
E-mail: jhorne at
PGP key available from public key servers

More information about the openssh-unix-dev mailing list