subject: ssh non-intuitive logging setting. (priority names)
Markus Friedl
markus.friedl at informatik.uni-erlangen.de
Sat Jan 6 23:03:07 EST 2001
On Sat, Jan 06, 2001 at 09:08:50AM +0900, Ishikawa wrote:
> Hi, thank you for the clarification.
i think this patch would help.
additionaly we should rename
SYSLOG_LEVEL_INFO to SYSLOG_LEVEL_NOTICE
this would be more appropriate?
comments?
commit?
cheers,
-markus
Index: log-server.c
===================================================================
RCS file: /home/markus/cvs/ssh/log-server.c,v
retrieving revision 1.17
diff -u -r1.17 log-server.c
--- log-server.c 2000/09/12 20:53:10 1.17
+++ log-server.c 2001/01/06 11:59:53
@@ -128,15 +128,17 @@
if (level > log_level)
return;
switch (level) {
- case SYSLOG_LEVEL_ERROR:
- txt = "error";
- pri = LOG_ERR;
- break;
case SYSLOG_LEVEL_FATAL:
txt = "fatal";
+ pri = LOG_CRIT;
+ break;
+ case SYSLOG_LEVEL_ERROR:
+ txt = "error";
pri = LOG_ERR;
break;
case SYSLOG_LEVEL_INFO:
+ pri = LOG_NOTICE;
+ break;
case SYSLOG_LEVEL_VERBOSE:
pri = LOG_INFO;
break;
More information about the openssh-unix-dev
mailing list