subject: ssh non-intuitive logging setting. (priority names)
Ishikawa
ishikawa at yk.rim.or.jp
Tue Jan 16 04:42:07 EST 2001
Hi,
After a busy week last week, I finally managed to check Markus's
patch to modification to log-server.c.
After the experimentation and reading the code,
I have summarized what I found about how opensshd
handles logging and verbosity control
at the following URL.
http://www.yk.rim.or.jp/~ishikawa/ssh-log-dir/ssh-log-patch.html
In the page, I added a slightly extended ugly patch
that I installed for a test installation.
The page is a quick hack. don't blame me for
html syntax errors.
Comments are welcome.
(Those of you who prefer text files, I could post
a text file that was the draft of the above web page.
It is about 20K bytes and is actually available
as .txt file at
http://www.yk.rim.or.jp/~ishikawa/ssh-log-dir/ssh-log-patch.txt
Markus Friedl wrote:
> On Sat, Jan 06, 2001 at 09:08:50AM +0900, Ishikawa wrote:
> > Hi, thank you for the clarification.
>
> i think this patch would help.
> additionaly we should rename
> SYSLOG_LEVEL_INFO to SYSLOG_LEVEL_NOTICE
>
> this would be more appropriate?
>
> comments?
> commit?
>
> cheers,
> -markus
>
> Index: log-server.c
> ===================================================================
> RCS file: /home/markus/cvs/ssh/log-server.c,v
> retrieving revision 1.17
> diff -u -r1.17 log-server.c
> --- log-server.c 2000/09/12 20:53:10 1.17
> +++ log-server.c 2001/01/06 11:59:53
> @@ -128,15 +128,17 @@
> if (level > log_level)
> return;
> switch (level) {
> - case SYSLOG_LEVEL_ERROR:
> - txt = "error";
> - pri = LOG_ERR;
> - break;
> case SYSLOG_LEVEL_FATAL:
> txt = "fatal";
> + pri = LOG_CRIT;
> + break;
> + case SYSLOG_LEVEL_ERROR:
> + txt = "error";
> pri = LOG_ERR;
> break;
> case SYSLOG_LEVEL_INFO:
> + pri = LOG_NOTICE;
> + break;
> case SYSLOG_LEVEL_VERBOSE:
> pri = LOG_INFO;
> break;
More information about the openssh-unix-dev
mailing list