OpenSSH 2.5.1 compatibility problem

mouring at mouring at
Fri Mar 2 10:46:28 EST 2001

You install OpenSSH how?

Redhat RPMs? RPMS?  (If your using this one you *MUST* run 0.9.6 OpenSSL)
Compiled it yourself?

Also have you tried 2.5.1p2?

- Ben

On Wed, 21 Feb 2001, Neal Barney wrote:

> SSH server specs:
> -----------------------
> Redhat Linux 6.2
> Custom built 2.2.17 kernel
> OpenSSL 0.9.5a (update from RedHat).
> OpenSSH 2.5.1p1
>          I am using my Linux box as an Internet gateway.  I wanted to keep 
> the box as secure as possible while still having the functionality I 
> needed.  The only way to connect to my server is through SSH.  A fair 
> majority of the time I am attempting to connect to the server from a 
> Windows box (whether at work, home, or on the road...).  The software that 
> I have used extensively in the past is a great little program called PuTTY 
> (  It supports SSH1 and 
> SSH2 protocols.  I have never had any problems in the past using these two 
> pieces of software together.  PuTTY has worked flawlessly with OpenSSH 
> 2.2.0p1 and 2.3.0p1.
>          However, using OpenSSH 2.5.1p1 PuTTY will no longer work.  PuTTY 
> will briefly flash a window and exit.  No error messages are given from 
> PuTTY.  However, the sshd daemon outputs the following line to the Linux 
> log file:
> Feb 21 10:13:04 rugen sshd[21915]: fatal: xfree: NULL pointer given as argument
> Everything works fine if I downgrade to OpenSSH 2.3.0p1.
> For completeness sake, I'll include some info about the client machine:
> PuTTY version:          0.51 (also downloaded snapshot on Feb 21st, 2001).
> OS:                             Windows 98
> Connection mode:                SSH
> Options selected:
> --------------------------
>          Connection
> Terminal type string            xterm
> Auto-login username             (blank) (also tried using local login name)
>          SSH
> Remote command          (blank)
> Attempt TIS or Cryptocard...    (not checked)
> Allows agent forwarding (not checked)
> Don't allocate a pseudo-term.   (not checked)
> Preferred Protocol vers.        SSH2
> Preferred Encryption algo.      3DES
> Imitate MAC bug in com...       (not checked)
> The author of putty (putty at has already been 
> contacted about this problem.  I hope that enough information was given and 
> is helpful in locating the problem.

More information about the openssh-unix-dev mailing list