Files >2GB?

Austin Gonyou austin at
Thu Feb 21 12:45:32 EST 2002

Looking at the source of 2.9* portable, there is no refernce to
largefile anywhere. 

3.0.x does just fine.

I was a little upset to see that cause in the 2.9px anouncment I found
on google, >2gb files was listed as a feature/fix. 

I'm having a little trouble getting the src rpm to compile
I'm going to just use the source..

the error I get is:

+ ./configure i386-redhat-linux --prefix=/usr --exec-prefix=/usr
--bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc/ssh
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info
--libexecdir=/usr/libexec/openssh --datadir=/usr/share/openssh
--with-pam --with-tcp-wrappers --with-rsh=/usr/bin/rsh
configure: WARNING: you should use --build, --host, --target
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
configure: WARNING: ****** Your snprintf() function is broken, complain
to your vendor
+ make
In file included from ../config.h:821,
                 from ../includes.h:22,
                 from bsd-arc4random.c:25:
../defines.h:238:59: operator '(' has no left operand
make[1]: *** [bsd-arc4random.o] Error 1
make: *** [openbsd-compat/libopenbsd-compat.a] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.90917 (%build)
    Bad exit status from /var/tmp/rpm-tmp.90917 (%build)

I thought it was cause I still had some src lying around from an attempt
at modifying the openssh.spec to ensure largefiles were enabled by
default, but that failed too with the same error. 

I deleted all my stuff(everything in
/usr/src/redhat/SOURCES|SPECS|BUILD), tried with a newly downloaded src
rpm and I get the same thing.

My configuration:

binutils 2.11.2(from source)
kernel 2.4.17-xfs-aa
gcc 3.0.3 (from source)
glibc 2.2.5 (from source)

Dual 933, Dell 1550.

On Wed, 2002-02-20 at 19:19, Damien Miller wrote:
> On Wed, 20 Feb 2002, Lacoss-Arnold, Jason wrote:
> > ./configure --enable-largefile
> > 
> > Which should be the default IMO, but hey, who asked me.
> It should be autodetected. I don't know whether 2.9 did the checking,
> but
> 3.02p1 should. Please report a bug if it does not work.
> -d
Austin Gonyou
Systems Architect, CCNA
Coremetrics, Inc.
Phone: 512-698-7250
email: austin at

"It is the part of a good shepherd to shear his flock, not to skin it."
Latin Proverb

More information about the openssh-unix-dev mailing list