mysterious connection breakdown

Tino Schwarze tino.schwarze at
Sat May 4 19:25:41 EST 2002

Hi there,
at a school I have two servers and I created a little backup "system"
for them. A cron job runs on the first server (fserver), backs stuff up
there and then ssh's to the second server to run a backup script there
too. (the first server is located in internal network, the second in a

When I tried everything on console, it worked fine, but when run from
cron, the connection mysteriously collapses.

Here is the output of my scripts (messages starting with +++ come from
my scripts and only inform of the progress).

----- Forwarded message from Cron Daemon <root at> -----

Delivered-To: tisc at
Date: Sat, 4 May 2002 10:49:00 +0200
From: root at (Cron Daemon)
To: tisc at
Subject: Cron <root at fserver> /root/daily_backup
X-Cron-Env: <MAILTO=tisc>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>

+++ 04.05,10:49 - Beginne Backup.
+++ 04.05,10:49 - Beginne Backup von communicator.
+++ 04.05,10:49 -   Kopiere Backup-Liste auf communicator.
> using scp to copy the list of things to back up
+++ 04.05,10:49 -   Starte Backup-Skript auf communicator.
> ssh -v www-intern /root/daily_backup.remote
OpenSSH_2.9.9p2, SSH protocols 1.5/2.0, OpenSSL 0x0090601f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Seeding random number generator
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: restore_uid
debug1: ssh_connect: getuid 0 geteuid 0 anon 1
debug1: Connecting to www-intern [] port 22.
debug1: temporarily_use_uid: 0/0 (e=0)
debug1: restore_uid
debug1: temporarily_use_uid: 0/0 (e=0)
debug1: restore_uid
debug1: Connection established.
debug1: read PEM private key done: type DSA
debug1: read PEM private key done: type RSA
debug1: identity file /root/.ssh/identity type 0
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_2.9.9p2
debug1: match: OpenSSH_2.9.9p2 pat ^OpenSSH
debug1: Local version string SSH-1.5-OpenSSH_2.9.9p2
debug1: Waiting for server public key.
debug1: Received server public key (768 bits) and host key (1024 bits).
debug1: Host 'www-intern' is known and matches the RSA1 host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug1: Encryption type: 3des
debug1: Sent encrypted session key.
debug1: Installing crc compensation attack detector.
debug1: Received encrypted confirmation.
debug1: Trying RSA authentication with key '/root/.ssh/identity'
debug1: Received RSA challenge from server.
debug1: Sending response to host key RSA challenge.
debug1: Remote: RSA authentication accepted.
debug1: RSA authentication accepted by server.
debug1: Sending command: /root/daily_backup.remote
debug1: Entering interactive session.
debug1: fd 1 setting O_NONBLOCK
> this is strange, there should be a message "+++ ... Beginne Backup"
> there should also be messages inserted for debugging purposes
> after all, there are three lines of output missing
+ echo starting
+ read filesystem archivename taroptions
+ echo filter comment
Disconnecting: Corrupted check bytes on input.
> !!! This usually points to a CRC compensation attack but this is
> rather unlikely since it's an internal server.
debug1: Calling cleanup 0x8065650(0x0)

----- End forwarded message -----

Any hints? What goes wrong here?

Bye+Thanx! Tino.

             * LINUX - Where do you want to be tomorrow? *

More information about the openssh-unix-dev mailing list