[Bug 194] still problems with libutil

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Sat May 11 23:29:34 EST 2002


------- Additional Comments From dh at onclick.org  2002-05-11 23:29 -------
Wow, much going on now :)

I already read Ben's message about finishing the flame war. I don't want to
flame further, just state what I state now since three messages. Gert, again,
wrote me about his "bigger dig", and appended some details about his good
relations to RMS, Linus, etc. (He enforced a useless flame war about the term
free source and its impact on the user in his previous email). I definately
don't agree with:

"Always remember: this is volunteer effort.  You don't pay for it.  The
ONLY right you have is "help yourself"." 

He always sticks to free as in free beer. He should proof his opinion with RMS
again. But, the most disturbing point is this "do or dare" opinion. I did not
criticize free source, was just angry about YOUR support. This is something
individual and not defined by the GPL, FSF, or the community. And, as a
dependent user *I have the right* to find out on whom I am dependent. But, ok,
have said this, lets skip now. I now see that over months nothing happened here
till I got more harsh. Now, everybody takes part with his comments. So, there is
never enough time for support but always for flame wars. This is a bad truth not
only for this project. I agree to ben:

"Gert, if anyone should be getting pissed by his messages it should be me
or maybe Damien."

There are actually some more helpful people. Ben, I want to excuse because you
seem to care. 

"If you take my original message or this one as being 'condensing' or
'elitest' non-sense then please stop reading into my writing because I'm
not. I'm honestly trying to find the right question or bit of
information that may help."

It wasn't clear at the beginning because the first messages were, say, not that

Now, there still is the problem with atexit(). You, and others, asked if I could
try appending /usr/lib/libc_nonshared.a to LIBS=. This way of co-operation I
seekd for. I tried but still the same referencing error with libutil. 

As I wrote, the error does not happen to my own prog and thousands of other free
source products. Thus, I don't think that glibc messes up something. It still
seems to be a referencing problem of the configuration and installation
procedure. I did not have to link to any place to let my own prog run. GCC found
everything needed and atexit worked. This is my experience, what shall I say.

You say: "I've not had anyone bring up this issue and so it leads me to believe
there is some uniqueness of your system.  Not saying that it is broken, but
something unique enough to trigger it.  What that means is will be impossible
for anyone, but you to resolve it since no one else can reproduce it."

I think this is at least a bit incorrect because of my overall good experience.
My system is just non-manipulated source, as it should be. It works fine and
clean. I was never happier about a linux system. I love it (slime). So, even if
this is unique to you, still your product does something that others do not.
Means: my system is only unique and triggering to openssh. So, maybe, openssh
does something unique under thousands of products (we can now start the next
flame war). I still stick to autoconf or similar as the culprit. As a
consequence, it does not help to bore the glibc-people. They will send me back
to you. I am not a jo-jo and don't want to be pushed from here to there. Maybe
you can now start just giving some hints. Maybe I could send config.cache and
makefiles to you. Maybe there are other things I could try. 

Please, you are more experienced in such big projects. You may know better what
to do now. I would ask Gert because of his relations to the masters of free
source but this is not a good deal, I believe.

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openssh-unix-dev mailing list