ssh works fine, scp fails

Martin Pitt martin at
Sun Jun 15 22:21:41 EST 2003

Hi everybody!

Am 2003-06-15 21:17 +1000 schrieb Darren Tucker:
> Martin Pitt wrote:
> > I have the following problem: ssh works very fine, but scp fails as
> > soon as it wants to start the actual transfer:
> [snip]
> > Read from remote host Connection reset by peer
> > debug1: Transferred: stdin 0, stdout 0, stderr 59 bytes in 0.2 seconds
> > debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 254.7
> > debug1: Exit status -1
> > lost connection
> This looks like an issue at the server end, either something like the
> shell being set to /bin/false or the server is crashing. 

No, I think that is not the case because of the following:

- I can ssh to this machine
- I tried it in both directions (i. e. issuing the scp command also on
  the remote host in a ssh session)
- it works with my old ISP
- it works with scp2 (commercial version)

> What does the server log say?

Nothing fancy:

Jun 15 14:20:23 paprika sshd[13368]: Accepted publickey for pitt from port 33024 ssh2
Jun 15 14:20:24 paprika PAM_unix[32033]: (ssh) session opened for user pitt by (uid=1016)

Authentication works properly as I already explained. The connection
is reset as soon as the data transfer is to be started.

>'s scp2 uses the sftp protocol.  Try using sftp instead.  I suspect
> that's all the server is configured to allow.

Negative (see above), scp works on this server. sftp gives exactly the
same error message.

Thanks for your answer, for future hints and have a nice day!

Martin Pitt
eMail: martin at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the openssh-unix-dev mailing list