Execution problems with 3.4.p1 and 3.6.p1

Koenig, Jeff Jeff.Koenig at experian.com
Thu May 29 05:18:30 EST 2003

I think your problem is that you are using the wrong "strip" program.

You want to use Sun's /usr/ccs/bin/strip instead of /usr/local/bin/strip.

To test this out, try renaming the /usr/local/bin/strip to
cd /usr/local/bin
mv strip strip_gcc

Then type "which strip" and your output should be:
% which strip

Now try recompiling OpenSSH and it should work for you.

You can do a search on Google newsgroups to find out more info on this:

Search for "/usr/ccs/bin/strip" and "ELF".


> -----Original Message-----
> From: Carl E. Roeder [mailto:croeder at asrr.arsusda.gov]
> Sent: Wednesday, May 28, 2003 12:40 PM
> To: openssh-unix-dev at mindrot.org
> Subject: Execution problems with 3.4.p1 and 3.6.p1
> Folks,
> I have installed openssh-3.1.p1 and 3.4.p1 successfully
> int the past.  When I tried to install 3.6.p1 it would
> not start.  The init script created an error message to
> the affect the it could not find *ELF*.  I the tried to
> reinstall 3.4.p1.  It's startup said Error 255 .../sshd .. bailing.
> I then installed Solaris patch for /dev/random and reinstalled
> 3.4.p1...  I got error ....  sshd: Cannot findELF  Error 137 ...
> bailing.
>  This is on SUN Solaris 8 with prngd and openssl-0.9.6j.
>  The only changes have been Solaris Recommended_8 patches and
>  Solaris security patches.  
>  Where can I find these Error messages?
>  I'll checked the lists but was unable to find any references.
>  Thanks for any assistance you can provide.
> Carl E. Roeder  croeder at asrr.arsusda.gov
> U.S.Department of Agriculture 
> Agricultural Research Service
> Alternate Crops and Systems Laboratory
> Beltsville, MD 20705   301/504-5844  fax 301/504-5823
> _______________________________________________
> openssh-unix-dev mailing list
> openssh-unix-dev at mindrot.org
> http://www.mindrot.org/mailman/listinfo/openssh-unix-dev

More information about the openssh-unix-dev mailing list