Problem with OpenSSH =>3.7p1 on Linux \w Linux-PAM 0.77

Pauli Borodulin pauli.borodulin at
Sun Oct 5 05:29:36 EST 2003


I'm currently running OpenSSH 3.6.1p2 successfully on older Slackware 
Linux. Glibc in use is 2.2.2 and Linux-PAM 0.77. I have been compiling 
OpenSSH for couple years until now with options

     --sysconfdir=/etc/ssh --with-ipv4-default --with-pam \
     --without-shadow --disable-suid-ssh

Unfortunately, upgrading to =>3.7p1 makes PAM-authentication fail. 
Authentication simply fails every time I try to log in. Even running 
"sshd -ddd" it only prints line "Failed password..." or similar on 
failure so debugging is hard.

Sure, I remembered to add "UsePAM yes" to my sshd_config. I tried 
removing PAM-file for sshd to see if PAM is even called at all. It seems 
that it is not. I have "other"-file which logs PAM-warn in syslog, but I 
didn't get it at all. 3.6.1p2 logs warning correctly from PAM this way.

I wondered if anyone would know what change in code would cause this 
problem. I tried running diff across 3.6.1p2 and 3.7p1 but there's way 
too many changes that I could be able to go thru' them.

Best regards,
Pauli Borodulin <pauli.borodulin at>

More information about the openssh-unix-dev mailing list