ssh not resolving host names on HP-UX 11i

Tom Orban TORBAN at
Wed Oct 29 05:09:49 EST 2003

I posted a message about this problem late last week, never heard
anything back, so I have to assume other folks did get a working ssh
(3.7.1p2) binary built on HP-UX 11i. Just to refresh, my ssh package
that I built on HP-UX 11i works fine, except that the ssh binary doesn't
seem to go to DNS to resolve host names.  So the only way I can ssh to
other machines is to put their host entries in my /etc/hosts file, or
type their IP address instead of the hostname on the command line. 
Since that's a really unsustainable workaround, I've grabbed the 3.7.1p2
ssh binary that I built on an hp-ux 11.00 box and use it with the rest
of the package that I build on 11i.  Ugly, but it seems to work.

In the meantime, I tried to boil down the build of the ssh package to
the bare essentials.  I stripped out the tcp_wrappers, and built with
zlib-1.1.4, and openssl 0.9.7c.  My "configure" lines look like this for

CFLAGS="+O2 -Ae -I/usr/local/include"
export CFLAGS
./configure --with-pam

on openssl, I use the following (since config seems to want me to use
Configure and declare what type of HP-UX build to use):

./Configure zlib no-shared -I/usr/local/include  hpux-parisc-cc

Stripping down didn't make any difference, I still get the "ssh:
hostname: host nor service provided, or not known" error message.

FYI, I'm using the HP KRNG* package for /dev/*random, and build
everything with the HP Ansi C compiler.

Can anyone who has built ssh (3.7.1p2) on an 11i box, and found it to
work properly, share what config parameters they used?



More information about the openssh-unix-dev mailing list