3.6.1p1/SNAP-20030910, AIX & /etc/nologin (similar to bug #178)

Darren Tucker dtucker at zip.com.au
Tue Sep 16 18:26:30 EST 2003

David Bronder wrote:
> For the purpose of testing, I've tried one line with just the text
> "testing sshd and nologin" (including newline at the end), and two
> short lines of text with a blank line between (60-odd bytes).

I just tried it with the current CVS tree (AIX 5.1 ML4) and it worked
(although it printed the contents of nologin twice, not sure why).  No
hangs though.  Will build and test 3.6.1p1 to match your config.

$ ssh zilker  -p 2022
testing sshd and nologin

User dtucker not allowed because /etc/nologin exists
testing sshd and nologin

Connection to zilker closed.

Hmm, actually I think the contents of /etc/nologin gets returned by
loginrestrictions() which would explain why it got printed twice: once by
printf("%s", loginmsg) and once by do_motd.

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list