3.6.1p1/SNAP-20030910, AIX & /etc/nologin (similar to bug #178)

Darren Tucker dtucker at zip.com.au
Tue Sep 16 19:01:20 EST 2003

Darren Tucker wrote:
> David Bronder wrote:
> > For the purpose of testing, I've tried one line with just the text
> > "testing sshd and nologin" (including newline at the end), and two
> > short lines of text with a blank line between (60-odd bytes).
> I just tried it with the current CVS tree (AIX 5.1 ML4) and it worked
> (although it printed the contents of nologin twice, not sure why).  No
> hangs though.  Will build and test 3.6.1p1 to match your config.

3.6.1p1 worked fine for me too.

A hunch: does this patch make a difference?

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.
-------------- next part --------------
Index: session.c
RCS file: /usr/local/src/security/openssh/cvs/openssh_cvs/session.c,v
retrieving revision 1.232
diff -u -p -r1.232 session.c
--- session.c	21 Mar 2003 01:18:09 -0000	1.232
+++ session.c	16 Sep 2003 08:59:09 -0000
@@ -1197,7 +1197,8 @@ do_nologin(struct passwd *pw)
 		while (fgets(buf, sizeof(buf), f))
 			fputs(buf, stderr);
-		fflush(NULL);
+		fflush(stderr);
+		close(STDERR_FILENO);

More information about the openssh-unix-dev mailing list