SSHD 3.7.1p2 on HP-UX

Eric Cunningham ecunningham at
Tue Sep 30 22:43:39 EST 2003

> Could you please check what sshd in debugging mode "sshd -ddd" reports
> about aging?


debug3: allowed_user: today 12325 sp_expire -1 sp_lstchg -1 sp_max 0
User eric password has expired (password aged)


> Could you please also check what
>   /usr/lbin/getprpw <username>
> reports about the account being rejected?

root:#-> /usr/lbin/getprpw eric
uid=5928, bootpw=NO, audid=10, audflg=1, mintm=-1, maxpwln=-1, exptm=-1, 
lftm=-1, spwchg=-1, upwchg=Fri Mar 31 15:18:43 2000, acctexp=-1, 
llog=-1, expwarn=-1, usrpick=DFT, syspnpw=DFT, rstrpw=DFT, nullpw=DFT, 
admnum=-1, syschpw=DFT, sysltpw=DFT, timeod=-1, slogint=Tue Sep 30 
08:26:48 2003, ulogint=Thu Sep 25 14:03:12 2003, sloginy=pts/ta, 
culogin=-1, uloginy=-1, umaxlntr=-1, alock=NO, lockout=0000000

For kicks, after this, I reset my password and tried again.  It worked. 
I hadn't thought my password was expired...I had no trouble logging in 
via non-ssh methods (ie, @console, telnet).  Thanks very much for the clues!

I'm a little embarrassed but grateful...


More information about the openssh-unix-dev mailing list