Problems after having crosscompiled for XScale

Rogier Stam rogier at
Mon Jun 12 02:42:59 EST 2006

Darren Tucker wrote:

> Rogier Stam wrote:
>> I tried porting OpenSSH-4.3p2 to arm-linux (IXP425 Xscale platform) > 
>> using openssl-0.9.8b and uClibc. This on the snapgear 3.2.0 
>> distribution. It all compiles without problems, but when i run any 
>> openssh executable it will always show output similar to the following:
>> # ssh
>> sh: /usr/bin/ssh: No such file or directory
>> #
>> I checked for the libraries, they are all in /lib. To give you an ls:
> [list of libs]
> seems to be missing.
> If that's not it, do you have ldd on your target, and if so what does 
> ldd /usr/bin/ssh say?
In the meantime i've tried openssh-4.0p1 and 4.2p1, all with the same 
results. I also found that this bug occurred before in 3.5, but wasn't 
solved due to incomplete bug report 
Should (in the case of a missing library) the name of the missing lib 
not be displayed? (assuming this is the case). Strangely enough i see 
(using ldd) a aside from my yet i have not 
specified it, and i link with the -nostdlib option. Where it comes from 
I don't know. Checking with arm-linux-objdump -x  doesn't show it 
either, nor does a grep -r. Could this be an errant message from the 
host compiled ldd?

More information about the openssh-unix-dev mailing list