Problems after having crosscompiled for XScale

Rogier Stam rogier at
Tue Jun 13 01:58:06 EST 2006

Just wanted to let you guys know what the reason was. The problem is 
that is not symlinked to the /lib/ file. 
Since I use uclibc. Default that one is not created, and while none of 
my other apps seem to have a problem with this, openssh apparently does....

Thanks for the help!


Darren Tucker wrote:

> Rogier Stam wrote:
>> I tried porting OpenSSH-4.3p2 to arm-linux (IXP425 Xscale platform) > 
>> using openssl-0.9.8b and uClibc. This on the snapgear 3.2.0 
>> distribution. It all compiles without problems, but when i run any 
>> openssh executable it will always show output similar to the following:
>> # ssh
>> sh: /usr/bin/ssh: No such file or directory
>> #
>> I checked for the libraries, they are all in /lib. To give you an ls:
> [list of libs]
> seems to be missing.
> If that's not it, do you have ldd on your target, and if so what does 
> ldd /usr/bin/ssh say?

More information about the openssh-unix-dev mailing list