No subject

Thu Nov 2 09:08:48 EST 2006

some_host$ ssh -R 20022:my_other_host:22 user at my_host

when I tried to connect to forwarded port from another computer, like this:

some_host$ ssh -p 20022 my_host

i got the message:

Connection refused.

When I tried to conect from the host my_host where the port was forwarded from 
like this:

my_host$ ssh -p 20022 localhost

it worked O.K. When I did it from the same my_host like this:

my_host$ ssh -p 20022 my_host

it failed again.

Forwarding of local ports form my_host works O.K. So by doing

my_host$ ssh -gL 20022:my_other_host:22 user at some_host

forwarding of port 20022 on my_host worked.

I should mention that my_host has a firewall installed, but the port 20022 was 
permitted. We tested it with putting sshd to listen on 20022:

my_host$ sshd -p 2002

and connecting to port 20022 from outside:

some_host$ ssh -p 20022

and it worked. So the firewall probably isn't the problem.

Port forwarding worked O.K. for other versions of SSH, only with OpenSSH it 

The OS is:

FreeBSD 4.8-RELEASE #6


i386 AMD Athlon(tm) Processor

The OpenSSH version is:

OpenSSH_3.5p1 FreeBSD-20030201

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openssh-unix-dev mailing list