Testing for the 4.4p1 release

David Bronder david-bronder at uiowa.edu
Thu Sep 7 06:58:47 EST 2006

Darren Tucker wrote:
> On Fri, Sep 01, 2006 at 08:14:51PM -0500, David Bronder wrote:
> > Damien Miller wrote:
> > > 
> > > The 4.4p1 release is approaching now, so we are now asking people to 
> > > actively test snapshots or CVS and report back to the mailing list.
> > 
> > [AIX 5.1 ML5, IBM VAC 6 compiler, openssh-SNAP-20060902]

I switched to openssh-SNAP-20060906 for the next attempt.

> > Fails to build.  See below for details.  Same result with a stripped
> > down configure line (just adding --with-zlib=/usr/local).
> [...]
> >           Compiler: cc -qlanglvl=ansi
> I noticed that in your other report in which it worked, you had "cc
> -qlanglvl=extc89" instead.  Does this make a difference to the TAILQ_HEAD
> error below?  (It appears that this line of the code has not changed
> for years.)

Yes, if I manually change the "langlvl" value from "ansi" to "extc89" in
the relevant Makefiles, it builds and tests cleanly (with the expected
skipped tests).  Looking at the config.log, configure didn't use "extc89"
because of this error:

configure:2734: cc -qlanglvl=extc89 -c -g  conftest.c >&5
"conftest.c", line 43.19: 1506-195 (S) Integral constant expression with a value
 greater than zero is required.

The line in question is in a section of the test program specifically
checking some IBM C 6 for AIX behavior.

> > "/usr/include/usersec.h", line 625.32: 1506-310 (I) The type "struct aud_rec" was introduced in a parameter list, and will go out of scope at the end of the function declaration or definition.
> The patch below should fix those.

Switching "langlvl" to "extc89" fixed these without applying the patch
to port-aix.h.

> [...]
> > "packet.c", line 162.12: 1506-010 (E) Macro TAILQ_HEAD invoked with a null argument for parameter name.
> Please see my query above about compiler flags.

Yeah, the "langlvl" change fixed this, too.

> > "/usr/include/paths.h", line 50.9: 1506-213 (S) Macro name _PATH_BSHELL cannot be redefined.
> > "/usr/include/paths.h", line 50.9: 1506-358 (I) "_PATH_BSHELL" is defined on line 322 of defines.h.
> Hmm, the "cannot be redefined" sounds like we need to fix those before the
> release.

Still had these with openssh-SNAP-20060906 and "langlvl=extc89".


Hello World.                                    David Bronder - Systems Admin
Segmentation Fault                                     ITS-SPA, Univ. of Iowa
Core dumped, disk trashed, quota filled, soda warm.   david-bronder at uiowa.edu

More information about the openssh-unix-dev mailing list