Can't connect client when runned from Windows Service

Adriana Rodean adrya1984 at
Tue Dec 16 03:22:30 EST 2008

Hi, thanks for replying.
I tried:

"C:/Program Files/OpenSSH/bin/ssh.exe"  -R 40201:localhost:50300 -o
TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2 -T
-N -i "C:/id_rsa" visma at

still doesn't connect when started as service.

With previous command it connected from windows service only if the
service was started as logged in user, but like this user had to input
username and password, that's why we need to start it as Network
Service or Local System or Local Service, that don't require password.
I am thinking that it allows to connect with user account because the
known_hosts file was previous created. As soon as i deleted that file
ssh asked if i am sure to connect to the linux machine because is not
known. If i answered yes known_hosts file was created in c:\documents
and settings\[user]\.ssh folder.

If i copyed the .ssh folder in c:\documents and
settings\NetworkService folder still didn't work.

Is it a way to make ssh not ask that first question (we can't input
yes from service)? or make it recognize the known_hosts file?
And is it a way to output the verbose to a file? Tried '-ddd' it said
invalid command.


More information about the openssh-unix-dev mailing list