Call for testing: OpenSSH-6.0

Petr Cerny pcerny at
Sat Feb 18 11:39:14 EST 2012

Damien Miller wrote:
> On Mon, 13 Feb 2012, Damien Miller wrote:
>>  Hi,
>>  OpenSSH 6.0 is almost ready for release, so we would appreciate testing
>>  on as many platforms and systems as possible. This release contains a
>>  couple of new features and changes and bug fixes. Testing of the new
>>  sandboxed privilege separation mode (see below) would be particularly
>>  appreciated.
> oops, the bit about the sandboxed privsep code is a carryover from the
> previous release and isn't mentioned in the feature list below after all.
> It could still do with some more testing though, as I don't recall seeing
> any reports from users who tried it.


testsuite passes on:
SUSE Linux Enterprise 11: x86-64
openSUSE/Factory (reasonably "cutting edge" repository): x86-64
Slackware-current: x86-32

I have also tried to run the testsuite in our automated build 
environment (to test several architectures and distributions), but all 
failed with at least of the following errors:

test connection multiplexing: status 4
test connection multiplexing: status 5
test connection multiplexing: status 44
Master running (pid=14631)
Exit request sent.
failed connection multiplexing
make[1]: *** [t-exec] Error 1

key option proto 1 from="" not allowed but should be
key option proto 1 from=""
key option proto 2 from=""
key option proto 2 from="" not allowed but should be
key option proto 2 from=""
failed key options
make[1]: *** [t-exec] Error 1

test try ciphers: proto 2 cipher acss at mac hmac-sha2-512-96
ok try ciphers
run test ...
ok yes pipe head
run test ...
FATAL: no sshd running on port 4242
make[1]: *** [t-exec] Error 1

I think these problems could be related to some missing system 
functionality that is generally not required in the build environment 
for building (e.g. it could be a missing or incorectly set up network 
interface). The build environment is usually a chroot or a VM (which in 
turn may be running in LPAR in the case of S/390, AFAIK). Can you give 
me a hint what could be the problem behind these errors?

Kind regards
Petr Cerny
Mozilla/OpenSSH maintainer for SUSE Linux

More information about the openssh-unix-dev mailing list