SSH from within OpenSSH

Hussain Akbar hussainakbar at
Thu Jan 10 22:35:48 EST 2013

This is a request for a How-To

I need to SSH from my Windows 7 laptop to several Linux machines that are
inside a secondary VPN.

To explain: I have a network (Call it LAN A), containing a few Windows 2K
servers, that is protected by a VPN. That network connects to another one
(call it LAN B), that has a few Linux server, over a separate site-to-site

>From outside (here) I have no access to LAN B as it only allows connections
from selected servers of LAN A.

I normally initiate a VPN session to LAN A, use Remote Desktop to open a
session on one of the W2K machines on LAN A, then use PuTTY to connect to
the desired Linux server.

Today, I tried OpenSSH. I installed it on the W2K server in LAN A.

Then I used PuTTY from my Laptop to W2K. Got the DOS prompt. One thing I
notice is that if I press any cursor key, W2K takes that to be a control
character. i.e. Pressing cursor and hitting enter gives and error: *'
command not found*. Yes, there is a single quote at the start.

Next, I used plink to connect to a Linux server on LAN B.

At signin, the last character seems to get missed. So if I type "root" as
userid I get prompted for the password for "roo", so I typed "rootA". Same
thing with the password, so I had to type and extra character after it to
sign in.

The cursor key still doesn't work, or works intermittently. e.g. in VIM I
have to press one cursor key and then hit the space bar, etc.

There appears to be some ANSI conversion going on and on the Linux command
line I get messages such as &0a not found. Sometimes it gets stuck in a
loop printing such messages by the hundred.


More information about the openssh-unix-dev mailing list