SSH from within OpenSSH

Ángel González keisial at
Fri Jan 11 09:26:32 EST 2013

On 10/01/13 12:35, Hussain Akbar wrote:
> Today, I tried OpenSSH. I installed it on the W2K server in LAN A.
You installed the OpenSSH ssh *server* ? Where did you get it from?

> Then I used PuTTY from my Laptop to W2K. Got the DOS prompt. One thing I
> notice is that if I press any cursor key, W2K takes that to be a control
> character. i.e. Pressing cursor and hitting enter gives and error: *'
> command not found*. Yes, there is a single quote at the start.
Yes, something seems to be wrong. Have you played with the different
options on PuTTY config? You don't have W2000 in an odd locale, do you?

> Next, I used plink to connect to a Linux server on LAN B.
> Issues:
> At signin, the last character seems to get missed. So if I type "root" as
> userid I get prompted for the password for "roo", so I typed "rootA". Same
> thing with the password, so I had to type and extra character after it to
> sign in.
Does it happen if you directly run plink from the remote desktop?
That would isolate it to the running of commands on W2K.

> The cursor key still doesn't work, or works intermittently. e.g. in VIM I
> have to press one cursor key and then hit the space bar, etc.
> There appears to be some ANSI conversion going on and on the Linux command
> line I get messages such as &0a not found. Sometimes it gets stuck in a
> loop printing such messages by the hundred.
> Help?
As a workaround, you could make a ssh tunnel (SSH/Tunnels). That way the
W2000 machine won't be processing your commands in any way (actually,
it could even have a keylogger installed, and it won't matter at all).

Still, it would be nice that it worked (even though Windows 2000 is well
beyond its End Of Life...).

More information about the openssh-unix-dev mailing list