raw 6.6p1 versus "ports" openssl 1.0.1g on FreeBSD

Eric Dynamic ecsd at transbay.net
Tue Apr 15 18:27:14 EST 2014

   Darren Tucker wrote:

#SHELL = /bin/sh

   Ok, that fixed the syntax error, but now I am getting this failure:
   This is after I re-downloaded FreeBSD's ports tree to get the latest
   ports/security/openssl (101g) and did a "make install" there;
   then in my compilation directory "/usr/local/openssh" I end up getting
   the below:
   synergy[378]# make -k host-key
   (cd openbsd-compat && make)
   gcc -o ssh-keygen ssh-keygen.o -L. -Lopenbsd-compat/
   -L/usr/local/openssl/openssl-1.0.1g  -Wl,-z,relro -Wl,-z,now
   -Wl,-z,noexecstack -fstack-protector-all -lssh -lopenbsd-compat
   -lcrypto -lutil -lz  -lcrypt
   Generating public/private rsa1 key pair.
   rsa_generate_private_key: key generation failed.
   *** [host-key] Error code 255 (continuing)
   1 error
   My command history (to have seen the same error no matter what) was
      370    1:06    make install
      371    1:12    make -k install
      373    1:14    make host-key-force
      375    1:17    make -k install-nokeys (no error in this case because
   no keys attempted generation)
      378    1:18    make -k host-key
   I don't know if the command is timing out or cannot create a valid key.
   Manual attempts at installing openssl,
   I could not find a compiler-target label that worked (that did not
   produce one or more of compiler errors,
   assembler errors, or linker errors) so I gave up and used whatever the
   FreeBSD ports people gave me.
   Presumably the openssh compilation is loading against a fresh and valid
   openssl 1.0.1g library so I'm not
   faulting that on the first guess.

More information about the openssh-unix-dev mailing list