Pulling stalls before 52MB (works via netcat)

mancha mancha1 at zoho.com
Sun May 4 14:14:01 EST 2014

On Sat, May 03, 2014 at 08:57:26PM -0700, Grant wrote:
> > I can push fine over ssh but pulling via rsync or scp always stalls
> > at about the same point which must be between 26MB and 52MB.  I can
> > pull via netcat just fine.  I've tried compiling HPN out of the
> > install on both the client and server and I've tried -C on the
> > client with the same result.  I'm on Gentoo.  Any ideas?
> I should have said I'm on openssh-6.6_p1-r1.
> - Grant


First off, the HPN patches will not be supported here so I recommend
doing all further debugging on this issue with a pristine OpenSSH.

Now, you mentioned you backed out HPN and the problem remains, so I'll
assume it's not HPN related.

The first thing that comes to mind is you're over-taxing Linux's
selective ack's. Try disabling with:

# echo 0 > /proc/sys/net/ipv4/tcp_sack

If that doesn't help, let's start getting more info, maybe some packet
logs around hang time and client-side and server-side logs.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.mindrot.org/pipermail/openssh-unix-dev/attachments/20140504/7a7edef7/attachment.bin>

More information about the openssh-unix-dev mailing list