Pulling stalls before 52MB (works via netcat)

Grant emailgrant at gmail.com
Mon May 5 02:08:44 EST 2014

>> > I can push fine over ssh but pulling via rsync or scp always stalls
>> > at about the same point which must be between 26MB and 52MB.  I can
>> > pull via netcat just fine.  I've tried compiling HPN out of the
>> > install on both the client and server and I've tried -C on the
>> > client with the same result.  I'm on Gentoo.  Any ideas?
>> I should have said I'm on openssh-6.6_p1-r1.
> The first thing that comes to mind is you're over-taxing Linux's
> selective ack's. Try disabling with:
> # echo 0 > /proc/sys/net/ipv4/tcp_sack

That didn't do it but switching to MTU 576 seems to have fixed it.  I
suspect the root of the problem is that I'm using an AT&T modem/router
with the server. I've had trouble using a proxy server there before
and I discovered that the attached modem/router doesn't send ICMP
responses. The solution proposed by AT&T was to put the modem/router
into bridged mode but it's remote so I haven't been able to do that.

Could this MTU discovery also point to the modem/router and could
putting it into bridged mode solve the problem? What can I do in the

Is it strange that netcat works with MTU 1500 and openssh doesn't?

- Grant

More information about the openssh-unix-dev mailing list