X11 forwarding not working.

dE de.techno at gmail.com
Sun May 24 02:56:05 AEST 2015


I'm having a difficult time getting X11 forwarding to work.

Since I've read the docs completely about this, this must be an SSH bug
which is likely because I'm using Gentoo as the SSH server.

When trying to forward X11 connections, I get

X11 connection rejected because of wrong authentication.
kwrite: cannot connect to X server XXXXXXXXX:10.0

Using command

ssh -Y -p 1111 -4 -i testkey test at

I'm not using any X11 library build with ipv6 support. I tried building
the relevant library (after seeing the dependency of the X11
application) with ipv6 support, but it was of no help.

Of course first I did not use -4.

In the server, I've tried disabling ipv6 support.

The following exists in sshd_config --
X11UseLocalhost no
X11Forwarding yes

I've tried xhost + on the client and the server (although it wont help
on the server).

Thank you for any assistance.

More information about the openssh-unix-dev mailing list