SCP verbose output truncated

Nico Kadel-Garcia nkadel at
Fri Mar 23 06:56:34 AEDT 2018

On Thu, Mar 22, 2018 at 2:47 PM, CLOSE Dave
<Dave.Close at> wrote:
> Fedora 27 x86_64. openssh-7.6p1-5.fc27.x86_64.
> If I run a simple command like, "scp -v file target:", I get a new
> prompt before all the output appears. Running interactively, I see all
> that output, though some of it is after the prompt. But if I put this
> command in a script, the output is truncated at the point where my
> prompt would have appeared interactively. I see a message like, "Shared
> connection to target closed."

I think part of the issue is that some of the output is to stderr.
stderr and stdout can overwrite each other in fascinating ways.

I'd urge you to use "scp -v foo bar 2>&1" to keep all of stderr and
stdout, and avoid overwriting one with the other.

> I've tried putting the command in the background (&) and waiting for it,
> using the LocalCommand option to add a wait, and redirecting output to a
> file. So far I can't find a reliable way to get all the output when
> running in a script. Any ideas?

Have you considered using "rsync -e ssh" instead of scp, to get more
meaningful dialogue for most transfers?

More information about the openssh-unix-dev mailing list