[Regression] OpenSSH 7.7p1 no longer tests on NonStop Port

Randall S. Becker rsbecker at nexbridge.com
Tue Jan 22 09:52:39 AEDT 2019

Hi All,

I finally got around to trying to test the 7.7p1 release on the HPE NonStop
Platform. 7.6p1 worked just fine - no issues at all.

In 7.7p1, when the agent test ran, the following happened (prior tests
worked perfectly):

	run test agent.sh ...
	Couldn't open logfile /home/git/openssh-portable/regress/ssh.log:
Permission denied
	agent fwd failed (exit code 1)
	failed simple agent test

This seems to be entirely correct, in that the log file is secured 600 by
the root user (we run sudo make tests), but the agent ssh is running as my
user. It is unable to open the ssh.log file and happily dies, killing the
rest of the test suite. The weird part is, this seems entirely correct. The
log file is open as root as mode 600, which my own user cannot possible
read, so the error message appears correct. The problem is that this tosses
the remaining tests.

I was wondering whether this is expected behaviour and if so, how to get
around it. The release otherwise seems to work, but I can't release it to my
community without it passing regression tests. The error report is really
early in the agent's stack trace:

#0  0x700e84a0:0 in log_redirect_stderr_to (
    logfile=0x8017e32 "/home/git/openssh-portable/regress/ssh.log") at
#1  0x700504e0:0 in main (ac=2, av=<optimized out>) at
#2  0x7004a9c0:0 in _MAIN () at \ATOM.$RLSE.T8432ACH.CPLMAINC:52

This is a variant of commit a0349a1c with our platform mods applied, but
none of the mods were hit at this point in the agent.

As a side note: we are that weird platform where root is 65535 and the
logged off user is 0, but that's not the case here. We have a rather large
set of changes that could be useful to make the user checks handle this,
which I can put into a Pull Request, and yet, we have this issue.

Any help would be appreciated. 


-- Brief whoami:
 NonStop developer since approximately 211288444200000000
 UNIX developer since approximately 421664400
-- In my real life, I talk too much.

More information about the openssh-unix-dev mailing list