[Regression] OpenSSH 7.7p1 no longer tests on NonStop Port

Darren Tucker dtucker at dtucker.net
Tue Jan 22 10:59:49 AEDT 2019

On Tue, 22 Jan 2019 at 12:01, Randall S. Becker <rsbecker at nexbridge.com>

> Hi All,
> I finally got around to trying to test the 7.7p1 release on the HPE NonStop
> Platform. 7.6p1 worked just fine - no issues at all.
> In 7.7p1, when the agent test ran, the following happened (prior tests
> worked perfectly):
>         run test agent.sh ...
>         Couldn't open logfile /home/git/openssh-portable/regress/ssh.log:
> Permission denied
>         agent fwd failed (exit code 1)
>         failed simple agent test

My guess is that this is due to a previous test creating ssh.log as root,
however offhand I can't think of any changes in that time frame that would
cause it.

Do you see the problem if you remove the log file and run the test in

$ SUDO=sudo make tests LTESTS=agent SKIP_UNIT=1

> We have a rather large set of changes

are these changes publicly available?

Darren Tucker (dtucker at dtucker.net)
GPG key 11EAA6FA / A86E 3E07 5B19 5880 E860  37F4 9357 ECEF 11EA A6FA (new)
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list