[Regression] OpenSSH 7.7p1 no longer tests on NonStop Port

Randall S. Becker rsbecker at nexbridge.com
Wed Jan 23 02:45:18 AEDT 2019

On January 21, 2019 19:00, Darren Tucker wrote:
> On Tue, 22 Jan 2019 at 12:01, Randall S. Becker <rsbecker at nexbridge.com>
> wrote:
> > Hi All,
> >
> > I finally got around to trying to test the 7.7p1 release on the HPE
> > NonStop Platform. 7.6p1 worked just fine - no issues at all.
> >
> > In 7.7p1, when the agent test ran, the following happened (prior tests
> > worked perfectly):
> >
> >         run test agent.sh ...
> >         Couldn't open logfile
> > Permission denied
> >         agent fwd failed (exit code 1)
> >         failed simple agent test
> >
> My guess is that this is due to a previous test creating ssh.log as root,
> however offhand I can't think of any changes in that time frame that would
> cause it.
> Do you see the problem if you remove the log file and run the test in
> isolation?
> $ SUDO=sudo make tests LTESTS=agent SKIP_UNIT=1

run test agent.sh ...
ok simple agent test
make[1]: Leaving directory '/home/git/openssh-portable/regress'
all tests passed

So that's a good thing. Operator error. When running the full test:

key option expiry-time valid
failed key options
Makefile:206: recipe for target 't-exec' failed

/home/git/openssh-portable/regress: cat failed-regress.log, failed-ssh.log #
are the same
trace: key option pty default
FAIL: key option failed default

trace: key option pty restrict,pty
FAIL: key option failed restrict,pty

/home/git/openssh-portable/regress: tail -7 failed-sshd.log
debug3: do_exec_no_pty: fork() in child
debug3: send packet: type 99
debug3: do_child: entering do_child()
debug1: permanently_set_uid: 25603/100
FAIL: key option failed restrict,pty
debug3: do_child: Shell path=/bin/ksh

So, better, but this is a new break for us.

> [...]
> > We have a rather large set of changes
> are these changes publicly available?

My GitHub fork for this is https://github.com/rsbeckerca/openssh-portable on
the Randall branch, which is work in progress. The 7.6p1 port changes are at
2abb363, representing the bulk of the work. 7.7p1 is from there upward to


More information about the openssh-unix-dev mailing list