Tru64 privsep patch testing

Toni L. Harbaugh-Blackford harbaugh at
Fri Aug 30 21:25:12 EST 2002

On Thu, 29 Aug 2002, David Potterveld wrote:

  > Hi Ben,
  > > I assume you are going against --current or a more recent snapshot.
  > Well, I was using 3.4p1. I just downloaded, patched, and built the
  > 20020826 snapshot. This does behave differently... I ran sshd interactively
  > (sshd -e -d -d -d) and tried to connect with a client. The privileged process
  > commits the same error as before. The difference is that now it doesn't
  > tear down the client session when it exits, and the client appears functional
  > (warning: not tested yet beyond simply getting a shell.)

Yes, I saw this too.

  > So it seems to me that
  > there is still something wrong in the logic: at this point, the privileged
  > process shouldn't be trying to launch another session on this tty, and it
  > just happens to work now because the unprivileged process is better isolated.

Could you help me follow the code here (I'm getting lost between the unprivileged
and privileged processes)?...

Where does the unprivileged process setup it's session?  Does setup_sia()
get called twice (once in the privileged process and once in the
unprivileged process) or is a different (non SIA) method used by the
unprivileged process?

Toni Harbaugh-Blackford                     harbaugh at
AlphaServer 8400 System Administrator
SAIC/NCI Frederick Advanced Biomedical Computing Center

More information about the openssh-unix-dev mailing list